Donnerstag, 5. Januar 2012

ORACLE SQL

CREATE TABLE UMSATZ_TABELLE (
JAHR NUMBER(4),
FILIALE VARCHAR2(2),
UMSATZ NUMBER(4)
)

INSERT INTO TABLE UMSATZ_TABELLE

INSERT ALL
INTO UMSATZ_TABELLE (JAHR ,FILIALE ,UMSATZ ) VALUES(2001,'A',1200)
INTO UMSATZ_TABELLE (JAHR ,FILIALE ,UMSATZ ) VALUES(2002,'A',2100)
INTO UMSATZ_TABELLE (JAHR ,FILIALE ,UMSATZ ) VALUES(2003,'B',1100)
INTO UMSATZ_TABELLE (JAHR ,FILIALE ,UMSATZ ) VALUES(2004,'B',2200)
INTO UMSATZ_TABELLE (JAHR ,FILIALE ,UMSATZ ) VALUES(2005,'B',3300)
SELECT * FROM DUAL

SELECT * FROM UMSATZ_TABELLE

SELECT FILIALE, SUM(UMSATZ)
FROM UMSATZ_TABELLE
GROUP BY FILIALE

Dienstag, 3. Januar 2012

Excel Strings in Zellen vergleichen

Vergleich zweier Zellen in Excel unter Berücksichtigung von Gross-/ Kleinschreibung.

=WENN(IDENTISCH(D2;'!E2);"true";"falsch")